Author Topic: UTI that didn’t go from first round of antibiotics  (Read 227 times)

Offline Winelover11

  • Full Member
  • ***
  • Posts: 189
  • Karma: +0/-0
    • View Profile
UTI that didn’t go from first round of antibiotics
« on: March 13, 2018, 06:34:14 AM »
I was hoping someone has also been through this because I feel like I’m going crazy! I got an UTI about three weeks ago. I took a weeks worth of antibiotics and it was better. I think it might have still been there because It was still burning while I was peeing, but it wasn’t  that bad. Now, a week later, I still have the bladder infection. I’ve taken two pills of the antibiotics and it hasn’t done anything so far. I took on last night and one this morning. Has anyone else had anything like this? I’ve only had one bladder infection before and that one went away after taking the antibiotics. I’m just alittle worried. I feel like I’m going to have it forever.

Offline Sarahmt102

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: UTI that didn’t go from first round of antibiotics
« Reply #1 on: March 14, 2018, 10:35:52 AM »
You won’t have it forever. I personally haven’t gone through it nor heard of anyone having one that won’t go away. I would be questioning if it is really a UTI since meds aren’t making it go away. Might have something else. I would go back to Dr!!! Be careful taking all those antibiotics. Make sure you’re taking some probiotics too. If you’re not educated on probiotics ask your Dr about them when you go back to your appointment! Hope this helps. Good luck dear.